php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9101
Submitted: 2001-02-04 13:37 UTC Modified: 2001-02-04 13:45 UTC
From: anagnost at teiath dot gr Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 4.0.4pl1 OS: suse linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: anagnost at teiath dot gr
New email:
PHP Version: OS:

 

 [2001-02-04 13:37 UTC] anagnost at teiath dot gr
I try this
 ./configure 
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking host system type... i686-pc-linux-gnu
checking for gawk... gawk
checking for bison... no
checking for byacc... no
configure: warning: You will need bison if you want to regenerate the PHP parsers.
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking whether gcc and cc understand -c and -o together... yes
checking whether ln -s works... yes
checking for flex... no
checking for lex... no
./configure: flex: command not found
checking for flex... lex
checking for yywrap in -ll... no
checking lex output file root... ./configure: lex: command not found
configure: error: cannot find output from lex; giving up

and stop heer
normaly i try this 

#! /bin/sh
#
# Created by configure

"./configure" \
"--with-adabas=/usr/lib/adabas" \
"--with-pgsql=/usr" \
"--with-mysql" \
"--with-tiff-dir" \
"--with-jpeg-dir" \
"--with-png-dir" \
"--with-ldap" \
"--with-imap" \
"--with-gd" \
"--with-zlib" \
"--with-xml" \
"--with-ttf" \
"--with-mcal=/usr/include/mcal/" \
"--with-ftp" \
"--with-db3" \
"--with-dbm" \
"--with-ndbm" \
"--with-gdbm" \
"--with-snmp" \
"--with-mm" \
"--with-gettext" \
"--with-config-file-path=/etc/httpd" \
"--with-apxs=/usr/sbin/apxs" \
"--with-exec-dir=/usr/lib/apache/bin" \
"--enable-versioning" \
"--enable-yp" \
"--enable-trans-sid" \
"--enable-inline-optimization" \
"--enable-track-vars" \
"--enable-magic-quotes" \
"--enable-safe-mode" \
"--enable-sysvsem" \
"--enable-sysvshm" \
"--enable-bcmath" \
"--enable-calendar" \
"--enable-memory-limit" \
"--enable-wddx" \
"--with-readline" \
"--with-openssl" \
"i386-suse-linux-gnu" \

but the output its the same

in  config.log is this

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:1288: checking for a BSD compatible install
configure:1341: checking whether build environment is sane
configure:1398: checking whether make sets ${MAKE}
configure:1444: checking for working aclocal
configure:1457: checking for working autoconf
configure:1470: checking for working automake
configure:1483: checking for working autoheader
configure:1496: checking for working makeinfo
configure:1526: checking whether to enable maintainer-specific portions of Makefiles
configure:1555: checking host system type
configure:1583: checking for gawk
configure:1617: checking for bison
configure:1617: checking for byacc
configure:1664: checking for gcc
configure:1777: checking whether the C compiler (gcc  ) works
configure:1793: gcc -o conftest    conftest.c  1>&5
configure:1819: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1824: checking whether we are using GNU C
configure:1833: gcc -E conftest.c
configure:1852: checking whether gcc accepts -g
configure:1884: checking how to run the C preprocessor
configure:1905: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1964: checking for AIX
configure:2005: checking for gcc option to accept ANSI C
configure:2058: gcc  -c -g -O2  conftest.c 1>&5
configure:2085: checking for ranlib
configure:2114: checking whether gcc and cc understand -c and -o together
"config.log" 55L, 2423C                                                                     1,1           Top
configure:2085: checking for ranlib
configure:2114: checking whether gcc and cc understand -c and -o together
configure:2129: gcc -c conftest.c -o conftest.o 1>&5
configure:2130: gcc -c conftest.c -o conftest.o 1>&5
configure:2135: cc -c conftest.c 1>&5
configure:2137: cc -c conftest.c -o conftest.o 1>&5
configure:2138: cc -c conftest.c -o conftest.o 1>&5
configure:2165: checking whether ln -s works
configure:2192: checking for flex
configure:2192: checking for lex
configure:2225: checking for flex
configure:2259: checking for yywrap in -ll
configure:2278: gcc -o conftest -g -O2   conftest.c -ll   1>&5
/usr/i486-suse-linux/bin/ld: cannot find -ll
collect2: ld returned 1 exit status
configure: failed program was:
#line 2267 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char yywrap();

int main() {
yywrap();
return 0; }
configure:2114: checking whether gcc and cc understand -c and -o together
configure:2129: gcc -c conftest.c -o conftest.o 1>&5
configure:2130: gcc -c conftest.c -o conftest.o 1>&5
configure:2135: cc -c conftest.c 1>&5
configure:2137: cc -c conftest.c -o conftest.o 1>&5
configure:2138: cc -c conftest.c -o conftest.o 1>&5
configure:2165: checking whether ln -s works
configure:2192: checking for flex
configure:2192: checking for lex
configure:2225: checking for flex
configure:2259: checking for yywrap in -ll
configure:2278: gcc -o conftest -g -O2   conftest.c -ll   1>&5
/usr/i486-suse-linux/bin/ld: cannot find -ll
collect2: ld returned 1 exit status
configure: failed program was:
#line 2267 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char yywrap();

int main() {
yywrap();
return 0; }
configure:2301: checking lex output file root


 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-04 13:45 UTC] jmoore@php.net
you need to make sure all the tools you need for compiling PHP are avalible on your system please see the installation in the manual http://www.php.net/manual/

from the output from you ./configure you need to install lex which can be found in any flex rpm (see http://rpmfind.net)

James
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 12 21:05:44 2022 UTC