php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #9095 Allow multiple directories in extension_dir
Submitted: 2001-02-03 21:11 UTC Modified: 2015-02-17 08:09 UTC
Votes:12
Avg. Score:4.7 ± 0.5
Reproduced:11 of 11 (100.0%)
Same Version:4 (36.4%)
Same OS:4 (36.4%)
From: leeym at caece dot net Assigned: krakjoe (profile)
Status: Closed Package: PHP options/info functions
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: leeym at caece dot net
New email:
PHP Version: OS:

 

 [2001-02-03 21:11 UTC] leeym at caece dot net
Could you please make extension_dir become a colon/semicolon delimitd string (just like include_path), because I wanna set more then one extension_dir in php.ini .

For example, I want to set extension_dir = ".:/usr/local/lib/php/extensions" so that I can both put  user-specified dymanic extensions in working directory and system-wide ones in /usr/local/lib/php/extensions.

Thank you.

--
Yen-Ming Lee

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-29 11:45 UTC] jani@php.net
-Summary: colon/semicolon delimitd extension_dir ? +Summary: Allow multiple directories in extension_dir -Package: Feature/Change Request +Package: PHP options/info functions -Operating System: FreeBSD-4.2-STABLE +Operating System: * -PHP Version: 4.0.4pl1 +PHP Version: *
 [2010-12-29 11:45 UTC] jani@php.net
See also bug #41310
 [2011-03-12 21:54 UTC] stuporglue at gmail dot com
Here's my use case: 

Our shared hosting allows us to set the extension_dir in our own php.ini file. I have compiled a couple of extensions for my own use. If I want to use the hosting provided extensions and my own extensions I currently have to copy the provided extensions into my extension directory. Not a big deal, but seems like it shouldn't be necessary.
 [2015-02-17 08:09 UTC] krakjoe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: krakjoe
 [2015-02-17 08:09 UTC] krakjoe@php.net
This is no longer necessary, since you can use an absolute path to load extensions not in extension_dir, see #41310.

Marking closed, sorry about the delay.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 20 23:01:21 2019 UTC