php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9059 SNMP compile issue
Submitted: 2001-02-01 17:23 UTC Modified: 2001-08-20 10:15 UTC
From: l dot brockman at videon dot ca Assigned:
Status: Closed Package: SNMP related
PHP Version: 4.0.4pl1 OS: Tru64 4.0f
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: l dot brockman at videon dot ca
New email:
PHP Version: OS:

 

 [2001-02-01 17:23 UTC] l dot brockman at videon dot ca
When I compile PHP using:

./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-snmp=/usr --with-gd --with-zlib --enable-static

I get the following error when starting Apache:

bash-2.04# /usr/local/apache/bin/apachectl start
Syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: Unresolved symbol in /usr/lib/libsnmp-0.4.2.so: vsnprintf
/usr/local/apache/bin/apachectl start: httpd could not be started

SNMP libs are under /usr/lib and headers are under /usr/include/ucd-snmp

If I take out the --with-snmp=/usr (It used to be in /usr/local/[lib|include], but I moved it to make sure the linker was finding it) it compiles fine (Just with no snmp support of course).

Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-13 01:22 UTC] rasmus@php.net
Is this still happening with the latest versions of PHP? 
 [2001-08-20 10:15 UTC] sniper@php.net
No feedback. If you have trouble with later releases
(4.0.6 , 4.0.7) reopen this bug report.

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 11:01:26 2019 UTC