php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #9051 $variable = () crashes the server
Submitted: 2001-02-01 11:31 UTC Modified: 2001-03-16 16:48 UTC
From: php-bug-report at future dot galanet dot net Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 4.0.4pl1 OS: Linux 2.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php-bug-report at future dot galanet dot net
New email:
PHP Version: OS:

 

 [2001-02-01 11:31 UTC] php-bug-report at future dot galanet dot net
<? $x = () ?>test

This code would result in a "The Document Contains No Data" page in Netscape and a Segmentation Fault error in the Apache log.

gdb backtrace:
#0  0x402239c1 in _zval_ptr_dtor () from /usr/lib/apache/1.3/libphp4.so
#1  0x402228f4 in execute () from /usr/lib/apache/1.3/libphp4.so
#2  0x4021f327 in execute () from /usr/lib/apache/1.3/libphp4.so
#3  0x4021ffca in execute () from /usr/lib/apache/1.3/libphp4.so
#4  0x4022bf1f in zend_execute_scripts () from /usr/lib/apache/1.3/libphp4.so
#5  0x4023d634 in php_execute_script () from /usr/lib/apache/1.3/libphp4.so
#6  0x40239d8f in apache_php_module_main () from /usr/lib/apache/1.3/libphp4.so
#7  0x4023a740 in send_php () from /usr/lib/apache/1.3/libphp4.so
#8  0x4023a77e in send_parsed_php () from /usr/lib/apache/1.3/libphp4.so
#9  0x8054064 in ap_invoke_handler ()
#10 0x8062d0c in ap_some_auth_required ()
#11 0x8062d68 in ap_process_request ()
#12 0x805ca49 in ap_child_terminate ()
#13 0x805cbdc in ap_child_terminate ()
#14 0x805ccf9 in ap_child_terminate ()
#15 0x805d1ab in ap_child_terminate ()
#16 0x805d86d in main ()
#17 0x400bedcc in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-01 20:12 UTC] sniper@php.net
Can you try the latest CVS snapshot from http://snaps.php.net/  ??
I can't reproduce this.

And what was the configure line you used to configure PHP ?

--Jani

 [2001-03-16 16:48 UTC] sniper@php.net
No feedback. And doesn't crash for me.
(gives a parse error)

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 13:01:23 2019 UTC