php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8995 Linebreakes is added to form input
Submitted: 2001-01-30 06:26 UTC Modified: 2001-03-03 15:50 UTC
From: affe at kiruna dot se Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.0.4pl1 OS: RedHat Linux 7.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: affe at kiruna dot se
New email:
PHP Version: OS:

 

 [2001-01-30 06:26 UTC] affe at kiruna dot se
In PHP 4.0.4pl1 form input started to behave strange. The problem is simular to Bug 8940 but also includes other problems.

It seems that it affects every form with encryptiontype set to "multipart/form-data".

Besides that the mimetype is bundled with the uploaded file (as explained in bug report 8940) every other field is affected.

Data from every other field in the form starts with a linebreak char, except for formobjects of type textarea. Textarea form fields starts with double linebreak chars.

Forms where a encryptiontype is unset are not affected.

It also looks like some kind of files (like tgz-compressed files) are affected otherwise, but I still don't know what the difference is or if there are any other file types that are affected simular to tgz-compressed files.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-03 15:50 UTC] lyric@php.net
I had the same problem, and it's fixed in CVS. It seems like the one bug was causing all the file-upload problems
See http://bugs.php.net/bugs.php?id=9298 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 23:05:52 2022 UTC