php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8977 Cannot load /usr/lib/apache/libphp4.so into server:
Submitted: 2001-01-29 05:37 UTC Modified: 2001-01-29 18:35 UTC
From: steve at bassi dot com Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 4.0.4pl1 OS: cobalt RAQ3 linux redhat
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: steve at bassi dot com
New email:
PHP Version: OS:

 

 [2001-01-29 05:37 UTC] steve at bassi dot com
when configuring PHP4 with curl-7.6 (./configure --with-mysql --with-apxs --with-curl --enable-track-vars)

when apache loads the libphp4.so, it detects that it also needs to load the libcurl.so object. But,it seems as if the full path to the libcurl.so file is not included in libphp and then, since libcurl is stored in a separate custom directory, it doesn't find it. 

You get an error message:

Setting up Web Service: Syntax error on line 32 of /etc/httpd/conf/httpd.conf: Cannot load
/usr/lib/apache/libphp4.so into server: libcurl.so.0: 
cannot open shared object file: No such file or directory 
/usr/sbin/httpd 

However PHP configures fine with an old version of curl, namely libcurl 7.4.2 





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-29 18:35 UTC] sniper@php.net
You should add the install path of curl to --with-curl option.
e.g. --with-curl=/opt/curl

And also you have to put the path of the libraries into /etc/ld.so.conf:
/opt/curl/lib

and then run:
# /sbin/ldconfig 

If this doesn't help, ask further questions on php-install@lists.php.net

--Jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 12:03:37 2021 UTC