php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8966 Newline before variables in forms with ENCTYPE="multipart/form-data"
Submitted: 2001-01-28 07:19 UTC Modified: 2001-03-03 17:14 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: brecht at sanders dot org Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 4.0.4pl1 OS: RedHat Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brecht at sanders dot org
New email:
PHP Version: OS:

 

 [2001-01-28 07:19 UTC] brecht at sanders dot org
Hi,
I upgraded to php-4.0.4pl1-3 and found that most of my fileupload forms didn't work properly.
As it turns out all variables passed from a form with ENCTYPE="multipart/form-data" seem to have a newline character prepended to their value.
This wasn't the case in previous versions.
I hope this gets fixed soon.
Sincerely
    Brecht Sanders (http://brecht.sanders.org/)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-03 15:55 UTC] lyric@php.net
Fixed in CVS
 [2001-03-03 17:14 UTC] sniper@php.net
Fixed -> closed.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 24 21:01:24 2020 UTC