php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8933 gettimeofday improvement suggestion
Submitted: 2001-01-26 08:24 UTC Modified: 2001-01-26 16:01 UTC
From: reijo dot vanhanen at helsoft dot fi Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.4 OS: W2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: reijo dot vanhanen at helsoft dot fi
New email:
PHP Version: OS:

 

 [2001-01-26 08:24 UTC] reijo dot vanhanen at helsoft dot fi
As implemented now, win32 gettimeofday does not give a consistent time because seconds and microseconds are collected with two different function calls.
A better solution, in my opinion, would be to use
win32 GetSystemTime function (together with mktime). This reduces accuracy to milliseconds, but time differences would be more reliable (no more extra 1 second errors in small times)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-26 16:01 UTC] derick@php.net
Report summmitted 2 times
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC