php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #8914 How about proxy settings for remote file ops?
Submitted: 2001-01-25 14:59 UTC Modified: 2001-08-12 15:15 UTC
From: jnich at att dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.4pl1 OS: Any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jnich at att dot com
New email:
PHP Version: OS:

 

 [2001-01-25 14:59 UTC] jnich at att dot com
It would be a highly useful addition to the remote file manipulation features of php if scripts could establish proxy settings for handling URLs that are not directly reachable from the server where php is running. Something like

$proxy_server = "proxy.mycorp.com:8000"; // hostname:port of proxy 
$proxy_use_for_ftp = 1; // 1 for send ftp through http proxy, 0 to not
$proxy_exclude_list = "*.mycorp.com;localhost" 
   // list of hosts/wildcards to bypass the proxy on




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-12 15:15 UTC] sebastian@php.net
Duplicate of Bug #6701.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 09 16:01:24 2019 UTC