php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8912 variable not passed to next page
Submitted: 2001-01-25 12:55 UTC Modified: 2001-05-22 21:05 UTC
From: matthias dot krehl at key-work dot de Assigned:
Status: Not a bug Package: Session related
PHP Version: 4.0.4pl1 OS: Windows 2000 Server (IIS5)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: matthias dot krehl at key-work dot de
New email:
PHP Version: OS:

 

 [2001-01-25 12:55 UTC] matthias dot krehl at key-work dot de
When using Cookies for session management everything works fine (the authentication part) but passing the values of the session variables. In the example below the existence of '$ident' is verified. But no chance to get its value: no 'echo' prints out anything!

-- example -----------------------------------

session_start();
if (!session_is_registered('ident')) {
	header ("Location: ../index.php"); 
}
// trying to retrieve $ident which is obviously known to the session
echo $ident;
echo $HTTP_COOKIE_VARS['ident'];
echo $HTTP_SESSION_VARS['ident'];
// just to be sure there is no interference with form data
echo $HTTP_POST_VARS['ident'];
echo $HTTP_GET_VARS['ident'];

----------------------------------------------

bye Matthias

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-02 05:39 UTC] matthias dot krehl at key-work dot de
Reloading the (second) page 'solves' the problem. $HTTP_SESSION_VARS['ident'] is then available. I.e., there seems to be reaaly something wrong, isn't it?

Matthias
 [2001-05-22 21:05 UTC] jmoore@php.net
Browser probably doesnt send correct cookie as it works on the second page.

- James
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 08:01:26 2019 UTC