|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8894 Upgraded to 4.0.4p1 from 4.0.4 caused apache to crash
Submitted: 2001-01-24 23:13 UTC Modified: 2001-01-26 13:16 UTC
From: pcory at nc dot rr dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.4pl1 OS: Red Hat Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
41 - 37 = ?
Subscribe to this entry?

 [2001-01-24 23:13 UTC] pcory at nc dot rr dot com
When I upgraded to 4.0.4p1 from 4.0.4 using the apxs mechanism, Apache (1.3.14) started crashing. I have both mod_perl and mod_php loading as DSOs.

Swapping the load order of mod_php and mod_perl in the httpd.conf file, so that mod_php loaded first, solved the problem (at least for the moment).

LoadModule php4_module        libexec/
LoadModule perl_module        libexec/


AddModule mod_php4.c
AddModule mod_perl.c


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-25 05:54 UTC]
What was the configure line used for PHP ?

 [2001-01-25 20:18 UTC]
User feedback:
./configure --with-mysql=/usr --with-pgsql=/usr 

Could you please try to generate a GDB backtrace of the crash?

 [2001-01-25 20:38 UTC]
I just installed mod_perl into my test system. No problems at all.
So how did you configure / compile mod_php ?
And did you do 'apachectl stop ; apachectl start' right after the update
of PHP ??? Could you please try changing the order of those directives
again and then do stop/start for apache again and see if it works?


 [2001-01-26 13:16 UTC]
User feedback:

Well, dammit. I just moved things back to where they were last night when 
they were failing, and they are working correctly now.

I apologize for getting you all all worked up. I thought I was being 

Solution: Just remember to stop / start apache when
you update ANY module in it.. :)

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 25 17:01:30 2024 UTC