|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #88 gmake test fails 80 of 86
Submitted: 1998-02-19 18:16 UTC Modified: 1998-02-19 20:17 UTC
From: ars at ziplink dot net Assigned:
Status: Closed Package: Parser error
PHP Version: 3.0 Latest CVS OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
30 + 37 = ?
Subscribe to this entry?

 [1998-02-19 18:16 UTC] ars at ziplink dot net
The latest CVS tree version of php fails 80 of 86 tests.
This is a fresh cvs checkout, then
./configure --with-mysql=/www1/users/ars/cgi-exec/mySql
--enable-safe-mode --enable-track-vars --enable-url-includes
--enable-debugger --prefix=/www1/users/ars/cgi-bin --enable-bcmath
"--bindir=\${exec_prefix}" --enable-maintainer-mode

gmake test

gmake bench works fine

It compiles fine (some warnings about missing declerations
and such).

This wouldn't matter so much if it actually worked on the web
sever, but it doesn't. I get no output watsoever from the web
server, not even content-type. The web server is a different
machine from where I compile it, but 3.0b4 worked as did
previous version of the cvs tree.

If I wrap php in a shell script (is that valid?)

Then I get
Memory fault

If I add a command above php in the shell script, that command
works fine. If I use php -i or -v it works in the shell script.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1998-02-19 20:17 UTC] zeev
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Sep 30 16:01:24 2023 UTC