php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8751 configure misdetects zlib on FreeBSD 4.1.1
Submitted: 2001-01-17 02:01 UTC Modified: 2001-01-17 14:35 UTC
From: webmaster at mocha dot dyndns dot org Assigned:
Status: Closed Package: PHP options/info functions
PHP Version: 4.0.4pl1 OS: FreeBSD 4.1.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: webmaster at mocha dot dyndns dot org
New email:
PHP Version: OS:

 

 [2001-01-17 02:01 UTC] webmaster at mocha dot dyndns dot org
When running configure for PHP 4.0.4pl1 on FreeBSD 4.1.1/i386, configure fails to properly detect FreeBSD's builtin zlib support. Zlib version 1.1.3 is preinstalled in /usr/lib/libz.{a,so}, however when configure tries to verify zlib's presence it says "zlib support requires zlib version >= 1.0.9" and terminates. It also complains that it can't find gzgets in -lz.

The exact command line I used was:
./configure --with-apxs --enable-sigchild \
--enable-magic-quotes --enable-bcmath --with-bz2 \
--with-gdbm --with-ndbm --enable-ftp --with-gd=/usr/local \
--with-jpeg-dir=/usr/local --with-xpm-dir=/usr/X11R6 \
--with-ttf --enable-gd-imgstrttf --with-imap \
--with-java=/usr/local/jdk1.1.8 --with-ldap --with-mhash \
--with-mysql=/usr/local --with-iodbc --with-pdflib \
--with-zlib-dir=/usr --with-png-dir=/usr/local \
--with-tiff-dir=/usr/local --with-mm --enable-trans-sid \
--with-zlib=/usr --enable-sockets \
--enable-inline-optimization --enable-memory-limit

Upon removing the --with-zlib flag, php compiles fine and works normally.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-17 14:35 UTC] webmaster at mocha dot dyndns dot org
I ran configure with those same flags again in order to gather some more information for you guys, and strangely enough it worked this time. I did a 'make clean' and 'rm config.cache' before running configure this time, so there must have been some bad information in the cache that caused it to fail on zlib those other times.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Sep 19 00:01:29 2019 UTC