php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8711 When I call the the ImageTTFText Function I receive a Segmentation Fault
Submitted: 2001-01-15 09:12 UTC Modified: 2001-06-27 22:34 UTC
From: gafain at fineware dot it Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.4pl1 OS: Linux Mandrake 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gafain at fineware dot it
New email:
PHP Version: OS:

 

 [2001-01-15 09:12 UTC] gafain at fineware dot it
      Header("Content-type: image/gif"); 
       $dims=ImageTTFBBox($size,0,$fontname,$text);
       $w=$dims[4]+$dims[6];
       $h=-($dims[5]+$dims[3]);
       $im = imagecreate($w,$h);
       $bg = splitColor($background);
       $fg = splitColor($color);
       $back= ImageColorAllocate($im, $bg[0],$bg[1],$bg[2]);
       $fore= ImageColorAllocate($im, $fg[0],$fg[1],$fg[2]);
       ImageFilledRectangle($im,0,0,$w,$h,$back);
       ImageTTFText($im, $size, 0, -1 ,$h-2 , $fore, $fontname, $text);
       ImageGif($im);
       ImageDestroy($im); 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-03 06:59 UTC] sniper@php.net
Please try the latest release candidate:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

Also, add a FULL example script which can be just copy/pasted and run to reproduce this. 
Also a GDB backtrace would be useful. Here are intructions
how to generate one:

http://www.php.net/bugs-generating-backtrace.php

--Jani

 [2001-06-27 22:34 UTC] sniper@php.net
No feedback. Can't reproduce.

 [2004-10-06 21:42 UTC] jason at axsystech dot net
I have the same problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 19:01:35 2019 UTC