php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8705 Compile fails with java support. Possibly due to compile script error?
Submitted: 2001-01-15 00:35 UTC Modified: 2001-07-22 12:45 UTC
From: pauldy3 at home dot com Assigned:
Status: Closed Package: Java related
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pauldy3 at home dot com
New email:
PHP Version: OS:

 

 [2001-01-15 00:35 UTC] pauldy3 at home dot com
Configure was run with the following options.

./configure --with-mysql --enable-inline-optimization --with-ldap=/usr/local --disable-debug --enable-track-vars --with-apxs=/usr/sbin/apxs --disable-short-tags --prefix=/usr --with-config-file-path=/etc/httpd --enable-safe-mode --with-exec-dir=/usr/bin --with-zlib --with-java=/usr/local/java --with-gd --with-png-dir --with-jpeg-dir --with-t1lib --enable-freetype-4bit-antialias-hack

The jdk1.2.2 file from java was used and an alias placed from /usr/local/jdk1.2.2 to /usr/local/java.  Then make was run and the following error was produced.

--- Begin Compile error ---
/root/httpdserver/php-4.0.4pl1/build/shtool mkdir -p net/php
javac net/php/reflect.java
/usr/bin/jar cf php_java.jar net/php/*.class net/php/*.properties
net/php/*.class: no such file or directory
make[3]: *** [php_java.jar] Error 2
make[3]: Leaving directory `/root/httpdserver/php-4.0.4pl1/ext/java'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/httpdserver/php-4.0.4pl1/ext/java'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/httpdserver/php-4.0.4pl1/ext'
make: *** [all-recursive] Error 1

--- End Compile error ---

I was able to complete the compile phase through the following steps.
From the php4.0.4pl1 dir I ran the following commands

cd ./ext/java/net/php/net/php/
cp reflect.class ../../
cd ../../../../../../
make

I then got a second error

--- Begin error ---
rmdir: net/php: Directory not empty
make[3]: *** [php_java.jar] Error 1
--- End error ---

I then ran the following commands.

cd ext/java/net/php/
rm -rf net
cd ../../../../

After rerunning make this time everything worked without a problem.  Hopefully this can be fixed in a later release.

Thanks for the kickin piece of software.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-22 08:41 UTC] sniper@php.net
Could you please try the PHP 4.0.6 as I can not reproduce
this bug. What exactly is your system? RH? Debian? 



 [2001-07-22 12:45 UTC] andy@php.net
no feedback
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 03:03:16 2021 UTC