php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8694 Date function core dumps with escaped chars
Submitted: 2001-01-13 22:41 UTC Modified: 2001-01-14 00:40 UTC
From: dirk at rackspace dot com Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.4pl1 OS: Red Hat 6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dirk at rackspace dot com
New email:
PHP Version: OS:

 

 [2001-01-13 22:41 UTC] dirk at rackspace dot com
<?
        $stamp=time();
   print(date("m d \o\f \t\h\e \w\e\e\k M F Y"));
 
?>

put the above code snippet in a file called test.php - run the php cgi from the command line 

php -q test.php

And it will core 

remove the \o\f \t\h\e \w\e\e\k and it works fine 
This used to work before 4.0.4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-13 23:54 UTC] rasmus@php.net
Unable to reproduce in current CVS - perhaps fixed.  Try a snapshot from snaps.php.net please.
 [2001-01-14 00:40 UTC] david@php.net
Fixed in CVS. Note also that "\t" produces a tab character. You probably want to use '\t' with single quotes instead. Or even better, date("m d")." of the week ".date("M F Y");
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jul 05 09:05:45 2022 UTC