php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #8681 Function arguments in 'global'
Submitted: 2001-01-12 13:11 UTC Modified: 2002-04-04 05:45 UTC
From: sven at devcon dot net Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0.4 OS: Linux/FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sven at devcon dot net
New email:
PHP Version: OS:

 

 [2001-01-12 13:11 UTC] sven at devcon dot net
function foo ($bar)
{
  global $bar;
  # ...
}

Opposite to php3, php4 doesn't warn you. This is now documented.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-22 10:52 UTC] stas@php.net
Not a bug.
 [2002-01-06 12:53 UTC] jan@php.net
so what is this anyway?
 [2002-04-04 05:45 UTC] sniper@php.net
There is no request for any change or feature here.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 19:03:37 2021 UTC