php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8574 Berkeley DB (dba) support
Submitted: 2001-01-07 05:08 UTC Modified: 2001-12-18 07:14 UTC
From: vinod at mundu dot com Assigned:
Status: Closed Package: DBM/DBA related
PHP Version: 4.0.4 OS: RedHat Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vinod at mundu dot com
New email:
PHP Version: OS:

 

 [2001-01-07 05:08 UTC] vinod at mundu dot com
PHP 4.0.4 gives me a "driver initialization failure" error when i try to use a dba function.  This is the function that i'm calling - 

$ret = dba_open("/tmp/testing.db","c","db3");

This is how i configured PHP - 

'./configure' '--with-apxs' '--without-mysql' '--with-pgsql' '--with-ldap' '--with-mcrypt=/usr/local/lib' '--disable-posix-threads' '--enable-sockets' '--enable-magic-quotes' '--enable-inline-optimization' '--with-db3=/usr/local/lib/BerkeleyDB.3.1/lib'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-08 03:50 UTC] vinod at mundu dot com
I tried using minimum options - 

./configure --with-apxs --without-mysql --with-db3=/usrlocal/BerkeleyDB.3.1/lib

but the problem still persists.  I even tried using the 'n' option instead of 'c' to the dba_open call.
 [2001-11-27 05:46 UTC] sander@php.net
Does this problem still occur with 4.0.6, the latest RC (http://download.php.net/~zeev/php-4.1.0RC3.tar.gz) or the latest CVS?
 [2001-12-18 07:14 UTC] sander@php.net
No feedback. Closing.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 11:01:24 2021 UTC