php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8570 php_java causes inetinfo memory address error
Submitted: 2001-01-06 04:40 UTC Modified: 2001-06-22 01:59 UTC
From: jason at hspace dot net Assigned:
Status: Closed Package: Java related
PHP Version: 4.0.4 OS: Windows 2000 Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jason at hspace dot net
New email:
PHP Version: OS:

 

 [2001-01-06 04:40 UTC] jason at hspace dot net
This is a critical bug that seems to have been introduced in the 4.0.4 release.

Run a PHP script that instantiates a Java object.
(ie. makes use of php_java)
Then shut down Windows, or log off user.
Windows will display an error message that
Inetinfo will shut down (memory address shown).

I haven't encountered this error before, so I think it was introduced in the 4.0.4 release.

I'm using Sun's Hotspot VM 2.0, and JDK 1.30_01

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-22 01:59 UTC] sbergmann@php.net
Can't reproduce with PHP 4.0.7-dev, Java 2 SDK 1.3 on Windows 2000 Profession SP2. Tested with jver.php.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 00:03:49 2021 UTC