php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8568 charset parameter on sybase_connect dos is disallowed
Submitted: 2001-01-05 16:10 UTC Modified: 2001-06-26 17:04 UTC
From: swba at ability dot com dot br Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.0.3pl1 OS: Red(R)at Linux 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: swba at ability dot com dot br
New email:
PHP Version: OS:

 

 [2001-01-05 16:10 UTC] swba at ability dot com dot br
we often get intermitent charset problems on database operations (onto sybase ase 11.0.3.3-6 using ctlib) and we are tring to find out an way to solve this. reading the php online doc, we discover that there is an parameter in the sybase_conection () function to force a charset for de client connection. unfortunately this does not work, as shown below:

Warning: Wrong parameter count for sybase_connect() in /home/oab/public_html/amaral_testes/lixo/sybase-fetch.php on line "x".

the code that generate this parse error was this:
<?php
...
$id_conn = sybase_connect ('SYBASE','sa','', 'iso_1');
...
?>

is this an BUG ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 08:50 UTC] joey@php.net
I have a patch all ready for this, it just needs some tweaking.
 [2001-06-26 17:04 UTC] joey@php.net
Fixed in CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 19 17:01:23 2021 UTC