php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8549 Writing more than one folder in doc_root (php.ini) is not understood by PHP.
Submitted: 2001-01-04 08:21 UTC Modified: 2001-01-04 08:37 UTC
From: fredgilles at iname dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.3 OS: Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fredgilles at iname dot com
New email:
PHP Version: OS:

 

 [2001-01-04 08:21 UTC] fredgilles at iname dot com
Example:
in php.ini:
  doc_root="e:\www;e:\www\site1"

I use Apache 1.3.12 for WinNT and PHP 4.0.3 for WinNT.
e:\www is the root of the default Web site. e:\www\site1 is the root of the virtual host "Site1".
In this example, no PHP scripts can run on Site1.

Frederic GILLES
--

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-04 08:37 UTC] hholzgra@php.net
this is intended behavior

you have to use 'php_value doc_root ...' in the 
virtual host sections of your apache config file
to set up different values for different virtual hosts
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 16:01:27 2024 UTC