php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8545 Session variables not carried forward in Netscape Client
Submitted: 2001-01-04 00:53 UTC Modified: 2002-06-27 22:52 UTC
Votes:8
Avg. Score:4.8 ± 0.4
Reproduced:7 of 7 (100.0%)
Same Version:2 (28.6%)
Same OS:2 (28.6%)
From: tvkbhaskar2011 at sify dot com Assigned:
Status: Not a bug Package: Session related
PHP Version: 4.1.1 OS: Linux RH 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tvkbhaskar2011 at sify dot com
New email:
PHP Version: OS:

 

 [2001-01-04 00:53 UTC] tvkbhaskar2011 at sify dot com
Went thru the bug database and could see similar bugs raised before, but unable to understand the exact solution for the same. Hence raising it again.
Session variables set in the previous page not getting carried forward in Netscape client alone. In IE it works fine.
Tried in Netscape 4.5 & 4.7. Result is same.
But works fine in IE 5.0 & 5.5.
Using the latest PHP from snaps.php.net

Kindly advise asap.
rgds
Bhaskar

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-04 07:55 UTC] sniper@php.net
Do you have cookies enabled in Netscape?

--Jani
 [2001-01-04 23:29 UTC] tvkbhaskar2011 at sify dot com
Yes the cookies are enabled in netscape client.

 [2001-01-06 20:36 UTC] sniper@php.net
Please include a short script which can be used to reproduce this.

--Jani
 [2001-01-08 03:33 UTC] tvkbhaskar2011 at sify dot com
I am attaching the script of two files first.php and second.php which can be used to reproduce this.

------------beginning of first.php-------------
<?
session_start();
session_register(test);
$test="firstpage";
?>
<html>
<head>
<title>Php Bug reporting page</title></head>
<body>
<a href="second.php">Click here to goto next page</a></table>
</body>
</html>
---------------------end of first.php-----------
---------------beginning of second.php-----------
<?
session_start();
echo $test;
session_unset();?>
<html><head>
<title>Php Bug reporting page</title></head>
<body>
<a href="first.php">Click here to goto first page</a></table>
</body>
</html>
----------------------end of second.php-------------

On clicking the hyperlink of the first page, i should see the value of variable test and an hyperlink. this comes in Ie and not in netscape.

hope this will help u in finding the problem i am having.

rgds
Bhaskar

 [2001-01-08 03:37 UTC] tvkbhaskar2011 at sify dot com
I am attaching the script of two files first.php and second.php which can be used to reproduce this.

------------beginning of first.php-------------
<?
session_start();
session_register(test);
$test="firstpage";
?>
<html>
<head>
<title>Php Bug reporting page</title></head>
<body>
<a href="second.php">Click here to goto next page</a></table>
</body>
</html>
---------------------end of first.php-----------
---------------beginning of second.php-----------
<?
session_start();
echo $test;
session_unset();?>
<html><head>
<title>Php Bug reporting page</title></head>
<body>
<a href="first.php">Click here to goto first page</a></table>
</body>
</html>
----------------------end of second.php-------------

On clicking the hyperlink of the first page, i should see the value of variable test and an hyperlink. this comes in Ie and not in netscape.

hope this will help u in finding the problem i am having.

rgds
Bhaskar

 [2001-01-08 04:42 UTC] tvkbhaskar2011 at sify dot com
I am attaching the script of two files first.php and second.php which can be used to reproduce this.

------------beginning of first.php-------------
<?
session_start();
session_register(test);
$test="firstpage";
?>
<html>
<head>
<title>Php Bug reporting page</title></head>
<body>
<a href="second.php">Click here to goto next page</a></table>
</body>
</html>
---------------------end of first.php-----------
---------------beginning of second.php-----------
<?
session_start();
echo $test;
session_unset();?>
<html><head>
<title>Php Bug reporting page</title></head>
<body>
<a href="first.php">Click here to goto first page</a></table>
</body>
</html>
----------------------end of second.php-------------

On clicking the hyperlink of the first page, i should see the value of variable test and an hyperlink. this comes in Ie and not in netscape.

hope this will help u in finding the problem i am having.

rgds
Bhaskar

 [2001-01-10 06:59 UTC] tvkbhaskar2011 at sify dot com
can i have the design team views asap.

thanks in advance
Bhaskar
 [2001-01-16 08:03 UTC] tvkbhaskar2011 at sify dot com
Hi,
an update on this.
This problem is observed if the server type in apache web server is INETD. If we run apache as standalone it works fine.

can u check this and revert why sessions are not working in netscape if apache runs as inetd.

rgds
Bhaskar
 [2001-02-27 18:17 UTC] sniper@php.net
Does this happen with latest CVS snapshot from http://snaps.php.net/ ??

--Jani

 [2001-02-28 04:03 UTC] tvkbhaskar2011 at sify dot com
hi,
observation is same even with the latest one.

rgds
Bhaskar
 [2001-06-14 23:12 UTC] sniper@php.net
Seems like the session_start() doesn set the cookie when
Apache is run in Inetd mode. Reproduced with PHP 4.0.6RC3

 [2002-01-06 22:13 UTC] yohgaki@php.net
Is this bug outstanding?
To reporter: please update PHP Version. (i.e. Try  with 4.2.0-dev)
 [2002-02-03 19:58 UTC] yohgaki@php.net
To reporter: Is this bug still in PHP 4.1.1?
 [2002-03-04 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-03-07 14:49 UTC] ahutt at hoecoop dot org
I get these results with RH7.0,Apache 1.3.22,PHP 4.1.1 (php.ini display_errors=on, register_globals= off) Netscape 4.75 (cookies,javascript on OR off) on my development workstation:

(first.php)
Use of undefined constant test - assumed 'test' in /var/www/hoecoop/html/auth/first.php on line 3
Click here to goto next page 


Warning: Undefined variable: test in /var/www/hoecoop/html/auth/second.php on line 3
Click here to goto first page 

Help !!!
 [2002-03-07 14:52 UTC] ahutt at hoecoop dot org
PS apache is running standalone, not xinetd.
 [2002-04-10 03:55 UTC] geoff at sinfield dot com
I am having the same problem...I am running apache 1.3.24 win32 in win2k AS...with php 4.1.1
 [2002-04-11 07:13 UTC] achim at ddd dot de
same for me:

php 4.1.1
apache 1.3.20

session.use_cookies = enabled/disabled
session.save_handler = files / user
session.use_trans_sid = enabled / disabled

makes no difference

just upgraded to 4.1.2 and everythings fine.

/achim
 [2002-06-27 22:52 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 26 18:01:26 2019 UTC