|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8541 Fieldtype doesn't work with PHP
Submitted: 2001-01-03 15:07 UTC Modified: 2001-03-09 21:22 UTC
From: daboheny at yahoo dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.4 OS: Windows NT/ 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
4 - 1 = ?
Subscribe to this entry?

 [2001-01-03 15:07 UTC] daboheny at yahoo dot com
I use:

PHP 4.04 ISAPI-Mode
SQL Server 2000
and ODBC.

Here the message:

FATAL: emalloc(): Unable to allocate 1073741824 bytes 

The problem seems (for me) to be the field NTEXT.
I changed the fields of type NTEXT to TEXT and it worked.

I first posted this problem on
James Moore (PHP QA Team) asked me to post the problem here.

So, how I said: After I changed all the database-fields of type NTEXT to TEXT, it worked perfect for me!

Hope I could help.



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-04 12:14 UTC]
This is not an error in the MS SQL extension, as you are using ODBC functions to fetch data.

Microsofts new datatypes ntext nad nvarchar is not suported in the MS SQL extension, as they are not supported in Microsofts C-library. The will always be returned as a varchar with a max length of 255 bytes.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun May 28 13:03:46 2023 UTC