php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8540 --enable-versioning and dynamic php extensions won't work on Solaris
Submitted: 2001-01-03 14:56 UTC Modified: 2001-03-16 16:07 UTC
From: hartmut at six dot de Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.4 OS: Solaris 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
35 + 16 = ?
Subscribe to this entry?

 
 [2001-01-03 14:56 UTC] hartmut at six dot de
When trying to get both PHP 3 and 4 Modules
working in a single Apache it is not possible
to load php 4 extensions dynamicly as shared objects

removing php 3 from the server setup does not help,
the problem is related to --enable-versioning

this is broken on solaris but works fine on linux ...

the error message is

PHP Warning:  Unable to load dynamic library
'.../no-debug-non-zts-20001214/sixcode.so' - 
ld.so.1: .../bin/httpd: fatal: relocation error: file .../no-debug-non-zts-20001214/sixcode.so: 
symbol alloc_globals: 
referenced symbol not found in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-03-16 16:05 UTC] hholzgra@php.net
1. this does not happen on linux, but on solaris

2. it should be enough to compile just the php 3 module 
with versioning so that dynamic loading in php 4 is not
affected 
 [2001-03-16 16:07 UTC] hholzgra@php.net
looks like i was talking to myself :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 06:01:25 2020 UTC