php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8530 system, exec and friends "unable to fork"
Submitted: 2001-01-03 09:11 UTC Modified: 2001-04-27 19:21 UTC
From: wez at ryltech dot net Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.4 OS: Windows NT Server 4.0 (SP 6a), w
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wez at ryltech dot net
New email:
PHP Version: OS:

 

 [2001-01-03 09:11 UTC] wez at ryltech dot net
<?php
system("dir");
?>

This causes apache to hang until you kill the request handling process using the task manager; the script then completes and produces the output:

Warning: Unable to fork [dir] in i:/cms.wwwroot/test/test.php on line 2

The same effect is evident with exec and popen.
The backtick operator causes Apache to GPF.

If you use the CGI version, things work as expected.

The binaries are those from php4win.de (php4.0.4-win32-20001210).

This sounds like a deadlock -- there is that mutex for chdir in the exec/popen code - maybe it's related to that somehow? Or perhaps it's more of an issue with Apache itself.

If you need more info, just let me know.

--Wez.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-03 11:12 UTC] derick@php.net
Duplicate of 4761
 [2001-01-03 11:12 UTC] derick@php.net
Duplicate of 4761
 [2001-04-27 19:21 UTC] sniper@php.net
Fixed in CVS. Wait for 4.0.6

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 25 23:01:28 2019 UTC