php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8509 ob_start doesn't work when passing ob_gzhandler as the function
Submitted: 2001-01-01 19:09 UTC Modified: 2001-05-11 21:14 UTC
From: johnh at solidtechnology dot com Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.4 OS: Redhat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: johnh at solidtechnology dot com
New email:
PHP Version: OS:

 

 [2001-01-01 19:09 UTC] johnh at solidtechnology dot com
This works: when wrapped in function ob_gzhandler works, really think the bug is with ob_start and internal functions.

<?php
function compress_output($output)
{
    return ob_gzhandler($output);
}
ob_start("compress_output");  
phpinfo();
?>
  
This doesn't:

<?php
ob_start("ob_gzhandler");
phpinfo();
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-02 09:21 UTC] sniper@php.net
Duplicate of #8334

--Jani
 [2001-05-11 21:14 UTC] sniper@php.net
Fixed in PHP 4.0.5

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 23 06:01:24 2020 UTC