php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8436 functions exec() and system() does not work properly (?)
Submitted: 2000-12-27 08:54 UTC Modified: 2001-04-27 12:51 UTC
From: r_przybysz at poczta dot onet dot pl Assigned: derick (profile)
Status: Closed Package: Program Execution
PHP Version: 4.0.4 OS: Windows NT 4.0 s.p. 6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: r_przybysz at poczta dot onet dot pl
New email:
PHP Version: OS:

 

 [2000-12-27 08:54 UTC] r_przybysz at poczta dot onet dot pl
I've found problems with executing this script:

<? 
exec("pkzip vv.zip aaa.dbf"); 
?>

(pkzip - dos zip version)

In Netscape 4.7. after first execute of it I get information:

Unable fork [pkzip vv.zip aaa.dbf]

All next executes probably cause suspending Apache. 
In PHP3 there was no  such problems.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-25 10:54 UTC] derick@php.net
Working on it
 [2001-04-27 12:51 UTC] dbeu@php.net
fixed in cvs, wait for 4.0.6
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Dec 10 02:01:24 2019 UTC