php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8435 trouble with xml_parse() function
Submitted: 2000-12-27 07:58 UTC Modified: 2001-02-15 08:01 UTC
From: herve dot maza at noos dot fr Assigned:
Status: Closed Package: XML related
PHP Version: 4.0.4 OS: win98 and redhat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: herve dot maza at noos dot fr
New email:
PHP Version: OS:

 

 [2000-12-27 07:58 UTC] herve dot maza at noos dot fr
I use PHP on Win98, installed with php-installer for CGI only. The server is Xitami.
The SAX parser for xml works fine with PHP 4.03p1, but a crash occurs with version 4.0.4 on the first call to xml_parse(). Win98 complains with this message :
       PHP.EXE a provoqu? l'erreur #c0000005 dans PHP4TS.DLL ? l'adresse 0257 : 1008e321

I encounter a similar problem on Linux (redhat 7.0 and apache 1.3.12).  Programs using xml_parse() work fine when apache uses module libphp4.so compiled from PHP 4.0.2 , but crash with libphp4.so compiled from PHP 4.0.4  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-15 08:01 UTC] thies@php.net
fixed in 4.0.4pl1
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC