php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8417 mssql_query return code not integer value
Submitted: 2000-12-25 11:13 UTC Modified: 2001-01-04 12:33 UTC
From: crispin at pchome dot com dot tw Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.4 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
32 - 21 = ?
Subscribe to this entry?

 
 [2000-12-25 11:13 UTC] crispin at pchome dot com dot tw
I try to use PHP + SQL Server 7.0 in Windows 2000. but I am found a bug of PHP's MSSQL API. The problem is mssql_query's return code is not integer value. The correct vlue may be null or string.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-04 12:33 UTC] fmk@php.net
mssql_query retuens TRUE, FALSE or a resource handler for the record set. Back in php3 days the resource handler was an integer, but with php4 this has changed. If a record set is available the return value will look like this "Resource id #2"
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 09:06:03 2022 UTC