php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8400 Problem with exec(), system(), passthru() and backtick operator
Submitted: 2000-12-24 07:01 UTC Modified: 2001-04-27 18:56 UTC
From: r dot j dot vrijhof at bigfoot dot com Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.4 OS: NT 4 Server SP 6a
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: r dot j dot vrijhof at bigfoot dot com
New email:
PHP Version: OS:

 

 [2000-12-24 07:01 UTC] r dot j dot vrijhof at bigfoot dot com
With the Apache module version of PHP (I use Apache 1.3.14), the binary download (so I didn't compile it myself), I have the problem that all program execution functions (and operator) fail with a warning like:

[24-Dec-2000 12:08:46] PHP Warning:  Unable to fork [at 12:13:46 D:\Winnt4\Batch\killTmpDownload.cmd 3a45d93e0e367] in e:/richy.dyndns.org/download/download.php3 on line 139

I haven't as yet tried program execution when running PHP as CGI, but my guess is that it WILL work as it has since long done.
For the rest, I'm very happy that finally I have the possibility to run PHP as Apache module on NT!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-03 11:10 UTC] derick@php.net
Duplicate of 4761
 [2001-04-27 18:56 UTC] sniper@php.net
Fixed in CVS. Wait for PHP 4.0.6

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 22:01:28 2024 UTC