php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8371 Crashes as CGI program
Submitted: 2000-12-22 05:25 UTC Modified: 2001-05-27 19:16 UTC
From: apyrski at yahoo Assigned:
Status: Closed Package: Other web server
PHP Version: 4.0.4 OS: Windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: apyrski at yahoo
New email:
PHP Version: OS:

 

 [2000-12-22 05:25 UTC] apyrski at yahoo
Using TinyWeb v1.9 (www.ritlabs.com), PHP (CGI Interface) produces no output, works OK at DOS prompt. Source code for TinyWeb Available at web site. This seems to be identical to Bug #3042 which was reported as closed/fixed. Problem was soved as follows:

1. Change GATEWAY_INTERFACE variable from CGI/1.1 to CGI/1.0
2. Remove variable HTTP_HOST from environment
3. Remove variable SERVER_PORT from environment

Unable to reproduce fault at DOS prompt.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-27 19:16 UTC] sniper@php.net
If this happens with PHP 4.0.6 (to be released rsn)
reopen this bug report.

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 15:01:29 2024 UTC