php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8338 URL fopen fails 1st time used on page
Submitted: 2000-12-20 11:56 UTC Modified: 2001-04-06 19:53 UTC
From: hank at yerpso dot net Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.0.4 OS: RHLinux 2.2.5-15
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 40 = ?
Subscribe to this entry?

 
 [2000-12-20 11:56 UTC] hank at yerpso dot net
Code works 4.03pl1 - breaks 4.0.4, running as DSO under Apache 1.3.14

$fd=fopen("http://www.linuxtoday.com/lthead.txt","r");

Throws a warning, unable to open, but tacks on "- success" at the end of the warning.  Later on the same page I have a similar url grab that works fine ... and even works fine accessing the same url as failed above.

I'm configured as follows, but have also tried without mcrypt as was suggested on the list to no avail.

'./configure' '--with-apxs=/usr/local/www/bin/apxs' '--with-mysql' '--with-gd=/usr/local' '--with-xml' '--enable-tracking-vars' '--with-imap=/usr/local' '--with-mcrypt=/usr/local'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-06 19:53 UTC] sniper@php.net
Should be fixed in CVS. Try latest snapshot from http://snaps.php.net/ 

Reopen this bug report if latest CVS doesn't work.

--Jani

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 20:05:50 2023 UTC