php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #8295 Allow using absolute path in extension= directive
Submitted: 2000-12-16 12:18 UTC Modified: 2010-12-03 17:17 UTC
From: bjoern at baer dot main dot de Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: * OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bjoern at baer dot main dot de
New email:
PHP Version: OS:

 

 [2000-12-16 12:18 UTC] bjoern at baer dot main dot de
Hi,

we had our extension fastsearch.so in /etc/httpd and in /usr/local/lib/php.ini
the following directive:

extension=/etc/httpd/fastsearch.so

PHP failed in loading this extension because it searched in:

/usr/local/lib/php/extensions/no-debug-zts-BUILDDATE//etc/httpd/fastsearch.so

As a workaround, I made a symlink, but I wonder why PHP doesn't accept extensions having in another path than /usr/local/lib/php/extension/... ?

TIA, Bj?rn.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-24 12:22 UTC] bjoern at baer dot main dot de
Has it been fixed already now in CVS? (Can't test it at the moment)
 [2001-01-03 10:17 UTC] stas@php.net
Did you try using extension_dir directive?
 [2001-01-03 10:28 UTC] bjoern at baer dot main dot de
Works with extension_dir now, but the extension directive should care about an absolute path.
 [2001-04-16 06:30 UTC] jmoore@php.net
This is the correct behaviour. WIll change to feature/change request.

-James
 [2010-12-03 17:15 UTC] jani@php.net
-Summary: absolute path in extension= directive in php.ini not recognized +Summary: Allow using absolute path in extension= directive -Package: Feature/Change Request +Package: PHP options/info functions -Operating System: Linux (SuSE 7.0) +Operating System: -PHP Version: 4.0 Latest CVS (16/12/2000) +PHP Version: *
 [2010-12-03 17:17 UTC] jani@php.net
-Status: Open +Status: Bogus
 [2010-12-03 17:17 UTC] jani@php.net
This is same as what is described in more recent bug #41310
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Sep 18 18:01:26 2020 UTC