php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #8185 date function crashes with T option
Submitted: 2000-12-09 15:05 UTC Modified: 2001-01-13 20:40 UTC
From: goba@php.net Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.2 OS: win2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: goba@php.net
New email:
PHP Version: OS:

 

 [2000-12-09 15:05 UTC] goba@php.net
For this code: echo date("Y-m-d H:i:s (T)");
PHP craches with sigsegv.

For that: echo date("Y-m-d H:i:s");
everything is fine.

I guess there is some problem with the (T)
element in the parameter. Maybe the () brackets.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-09 22:11 UTC] sniper@php.net
Duplicate of #7963
 [2001-01-13 20:40 UTC] sniper@php.net
This is fixed in CVS.

--Jani

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 01:03:33 2022 UTC