php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81687 Casting to int from array from boolean
Submitted: 2021-12-02 10:37 UTC Modified: 2021-12-02 11:01 UTC
From: cryptooman at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.4.3 OS: Ubuntu 20.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cryptooman at gmail dot com
New email:
PHP Version: OS:

 

 [2021-12-02 10:37 UTC] cryptooman at gmail dot com
Description:
------------
The issue is related to variables casting. Please see the small script at "Test script".
Regards

Test script:
---------------
echo (int) []; // Prints 0
echo (int) (array) false; // Prints 1, expected 0

OR
$x = false;
$x = (array) $x;
$x = (int) $x;
echo $x; // Prints 1, expected 0



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-12-02 10:42 UTC] cryptooman at gmail dot com
-PHP Version: 7.3.33 +PHP Version: 7.4.3
 [2021-12-02 10:42 UTC] cryptooman at gmail dot com
Changed PHP version
 [2021-12-02 11:01 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-12-02 11:01 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/language.types.type-juggling.php

Have you checked what the value of (array)false is?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 15:03:34 2022 UTC