php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81641 strpos() bug if search string is on first column
Submitted: 2021-11-19 16:17 UTC Modified: 2021-11-19 16:38 UTC
From: raxe at msn dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: Irrelevant OS: Windows 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: raxe at msn dot com
New email:
PHP Version: OS:

 

 [2021-11-19 16:17 UTC] raxe at msn dot com
Description:
------------
$full_string = "HELLOW WORD";
$search_string = "HELLOW";

if (strpos($full_string,$search_string)){ //This return false
  echo "True";
}else{
  echo "False";
}

Expected result:
----------------
True

Actual result:
--------------
False 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-11-19 16:38 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: *Regular Expressions +Package: Strings related
 [2021-11-19 16:38 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

https://www.php.net/manual/en/function.strpos.php
> Warning
> This function may return Boolean false, but may also return a non-Boolean value
> which evaluates to false. Please read the section on Booleans for more
> information. Use the === operator for testing the return value of this function.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 18:03:46 2023 UTC