php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81623 Successive SNMPv3 credential attempts fail (with valid credentials)
Submitted: 2021-11-15 06:27 UTC Modified: -
From: mark dot unwin at gmail dot com Assigned:
Status: Open Package: SNMP related
PHP Version: Irrelevant OS: Ubuntu Mate 21.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mark dot unwin at gmail dot com
New email:
PHP Version: OS:

 

 [2021-11-15 06:27 UTC] mark dot unwin at gmail dot com
Description:
------------
I have a network discovery application that takes an array of credentials and tests they work against SNMP devices. In this case, SNMPv3 devices. 

If I connect using a valid SNMPv3 credential set first in the array, things work as expected. 

If I connect using a bad set first in the array, the connection fails, as expected. 

If I connect using a valid SNMPv3 credential set second in the array (after the prior bad set), it fails.

This only seems to occur when using identical Security Names, but having otherwise different attributes.

Even if I unset the SNMP object in the loop each time, subsequent attempts to connect using valid credentials fail (as per above).

Test script:
---------------
Same code in SO question here - 

https://stackoverflow.com/questions/69491850/php-snmpv3-credentials-test-loop-failing

Expected result:
----------------
Should be able to connect using differing credentials after the object is unset, but even better if the object doesn't need unsetting.


Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 00:03:34 2022 UTC