php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #81418 Downoad en PHP documentation links broken
Submitted: 2021-09-05 17:59 UTC Modified: 2021-09-06 17:50 UTC
From: brad at lanier dot ws Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brad at lanier dot ws
New email:
PHP Version: OS:

 

 [2021-09-05 17:59 UTC] brad at lanier dot ws
Description:
------------
Download English version of documentation has multiple broken links in the html chunked version. Online documentation is not affected. ALL of the broken links resolve to html files that have an underscore (_) prepended to the actual file name.

After testing ALL of the broken links, it has been determined that ALL of the html files that have a leading underscore need to have the underscore removed.  This results in ALL of the broken links to be fixed. There is a one-to-one correlation with the file names having a leading (_) and the broken links.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-09-05 19:27 UTC] salathe@php.net
-Status: Open +Status: Feedback
 [2021-09-05 19:27 UTC] salathe@php.net
Please provide the URL for the download that contains broken file names.
 [2021-09-05 19:43 UTC] brad at lanier dot ws
-Status: Feedback +Status: Open
 [2021-09-05 19:43 UTC] brad at lanier dot ws
https://www.php.net/distributions/manual/php_manual_en.tar.gz

un-tar the file. In the php-chunked-xhtml folder, several .html files have an (_) prepended to the filename.  These _'s are causing the broken links.
 [2021-09-05 22:13 UTC] salathe@php.net
-Status: Open +Status: Feedback
 [2021-09-05 22:13 UTC] salathe@php.net
There are no files in the tarball at that URL, at present, whose filenames start with an underscore. 

If you download the tarball and list its contents without un-tarring (e.g using "tar -zvtf php_manual_en.tar.gz") does it show these files?  

Without more details or the ability to reproduce the problem, I am unable to assist further.
 [2021-09-05 23:31 UTC] brad at lanier dot ws
-Status: Feedback +Status: Open
 [2021-09-05 23:31 UTC] brad at lanier dot ws
I am sending a screenshot of what I just un-tared on windows platform to your email.  All files are in this screenshot.
 [2021-09-06 08:39 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-09-06 08:39 UTC] cmb@php.net
I see no files with leading underscores either, when untarring
with 7-zip or Window's tar (bsdtar 3.3.2 - libarchive 3.3.2
zlib/1.2.5.f-ipp).  Which program do you use to untar?
 [2021-09-06 17:23 UTC] brad at lanier dot ws
-Status: Feedback +Status: Closed
 [2021-09-06 17:23 UTC] brad at lanier dot ws
The problem was with the zip/tar package that I am using, Express Zip v7.23. If I explored the archive in the Express Zip application, all was well.  However if I expanded the archive directly without opening the GUI, the noted problem existed.

The newer version of Express Zip v8.24 does not have the problem.  Sorry for the distraction.
 [2021-09-06 17:50 UTC] requinix@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 23 15:03:34 2021 UTC