php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81374 Not same API version PHP and Module
Submitted: 2021-08-19 15:15 UTC Modified: 2021-08-19 16:08 UTC
From: dominique at ottello dot net Assigned: cmb (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 8.1.0beta2 OS: Windows 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dominique at ottello dot net
New email:
PHP Version: OS:

 

 [2021-08-19 15:15 UTC] dominique at ottello dot net
Description:
------------
PHP 8.1.0 beta 3
https://windows.php.net/downloads/qa/php-8.1.0beta3-Win32-vs16-x64.zip
Not same API version 

19-Aug-2021 14:58:13 UTC]
PHP Warning:  PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20201009
PHP    compiled with module API=20200930
These options need to match
 in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-08-19 15:20 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: Windows Installer +Package: *Configuration Issues -Assigned To: +Assigned To: cmb
 [2021-08-19 15:20 UTC] cmb@php.net
Looks like you have not updated your extension_dir INI setting, or
not restarted your Webserver.
 [2021-08-19 16:08 UTC] dominique at ottello dot net
Sorry,

When Apache is run as a service and PHP is used as an Apache module, when changing PHP version, a "Graceful Apache Restart" is not enough and a service restart must be used.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 13:04:05 2022 UTC