php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81315 imagefilledellipse - draws strange shape in large size
Submitted: 2021-07-30 18:00 UTC Modified: 2021-07-30 22:06 UTC
From: chzhdy at live dot com Assigned: cmb (profile)
Status: Duplicate Package: GD related
PHP Version: 8.0.9 OS: Windows 10 21H1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chzhdy at live dot com
New email:
PHP Version: OS:

 

 [2021-07-30 18:00 UTC] chzhdy at live dot com
Description:
------------
When the size of ellipse is larger than about 2200px, imagefilledellipse() will start to draw a strange shape. It seems that the problem only happens to "PHP for Windows", because the script works well on my Ubuntu Server.

[PHP Version]
PHP 8.0 (8.0.9) for Windows - VS16 x64 Non Thread Safe (2021-Jul-29 14:38:16)

Test script:
---------------
$w = 3000;
$h = 3000;
$im = imagecreatetruecolor($w, $h);
$color = imagecolorallocate($im, 0, 124, 255);
imagefilledellipse($im, $w / 2, $h / 2, $w, $h, $color);
header('content-type: image/png');
imagepng($im);

Expected result:
----------------
imagefilledellipse() can draw an ellipse while the size is large.

Actual result:
--------------
imagefilledellipse() draws a strange shape.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-30 22:06 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-07-30 22:06 UTC] cmb@php.net
This is a duplicate of bug #51498.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 21:03:39 2021 UTC