php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81289 Running php -v results in oci8.old_oci_close_semantics is deprecated message
Submitted: 2021-07-25 12:25 UTC Modified: 2021-07-25 12:49 UTC
From: dave_martin at mindspring dot com Assigned: cmb (profile)
Status: Closed Package: OCI8 related
PHP Version: 8.1.0beta1 OS: Windows 10 Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dave_martin at mindspring dot com
New email:
PHP Version: OS:

 

 [2021-07-25 12:25 UTC] dave_martin at mindspring dot com
Description:
------------
After installing beta 1 simply running php -v from a command window results in the following message:

Deprecated: Directive oci8.old_oci_close_semantics is deprecated in Unknown on line 0


Test script:
---------------
php -v

Expected result:
----------------
Expected the version details to be returned without the deprecated message. The deprecated message did not occur with the last alpha release.

D:\Temp>php -v

PHP 8.1.0beta1 (cli) (built: Jul 20 2021 17:20:01) (ZTS Visual C++ 2019 x64)
Copyright (c) The PHP Group
Zend Engine v4.1.0-dev, Copyright (c) Zend Technologies

Actual result:
--------------
D:\Temp>php -v

Deprecated: Directive oci8.old_oci_close_semantics is deprecated in Unknown on line 0
PHP 8.1.0beta1 (cli) (built: Jul 20 2021 17:20:01) (ZTS Visual C++ 2019 x64)
Copyright (c) The PHP Group
Zend Engine v4.1.0-dev, Copyright (c) Zend Technologies

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-25 12:33 UTC] dave_martin at mindspring dot com
This only happens when the oci8_19 extension is enabled in php.ini. When the extension is NOT enable the deprecated error is not shown when running php -v
 [2021-07-25 12:46 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-07-25 12:46 UTC] cmb@php.net
oci8.old_oci_close_semantics has only recently been deprecated[1].
Apparently you have enabled that setting in your php.ini.

[1] <https://github.com/php/php-src/commit/e120d5269a31cb40d422e8617428a430bcda78c1>
 [2021-07-25 12:49 UTC] kocsismate@php.net
-Status: Feedback +Status: Closed
 [2021-07-25 12:49 UTC] kocsismate@php.net
Thank you for the report! There was a bug in beta1 which made the deprecation notice always emitted. It has already been fixed in the meantime: https://github.com/php/php-src/commit/87c181a0b081999b49f50a14050ace6311923023

If you don't have oci8.old_oci_close_semantics enabled, then you won't see this notice as soon as you upgrade to beta2 (to be released ~2 weeks).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 05:05:45 2022 UTC