php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81278 OpenSSL v/3.0 compatibility
Submitted: 2021-07-21 13:48 UTC Modified: 2021-08-08 20:28 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: vvb at cybernet dot su Assigned: bukka (profile)
Status: Closed Package: OpenSSL related
PHP Version: 8.1.0alpha3 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vvb at cybernet dot su
New email:
PHP Version: OS:

 

 [2021-07-21 13:48 UTC] vvb at cybernet dot su
Description:
------------
Due to https://github.com/openssl/openssl/issues/14216 - RSA_SSLV23_PADDING removed from openssl-3.0.0_beta1.

After I remove RSA_SSLV23_PADDING from ext/openssl/openssl.c php built fine.

Also it's work for php-7.4 and php-8.0.


Patches

php-8.1-openssl3.patch (last revision 2021-07-21 13:52 UTC by vvb at cybernet dot su)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-21 13:52 UTC] vvb at cybernet dot su
The following patch has been added/updated:

Patch Name: php-8.1-openssl3.patch
Revision:   1626875538
URL:        https://bugs.php.net/patch-display.php?bug=81278&patch=php-8.1-openssl3.patch&revision=1626875538
 [2021-08-03 12:58 UTC] ramsey@php.net
-Assigned To: +Assigned To: bukka
 [2021-08-03 12:58 UTC] ramsey@php.net
A PR exists to fix this specific issue: https://github.com/php/php-src/pull/7002

This branch exists to track changes for OpenSSL 3.0 compatibility: https://github.com/php/php-src/compare/PHP-8.0...bukka:openssl_30
 [2021-08-08 20:28 UTC] bukka@php.net
The PR has been merged
 [2021-08-08 20:28 UTC] bukka@php.net
-Status: Assigned +Status: Closed
 [2021-08-08 20:28 UTC] bukka@php.net
-Package: Compile Failure +Package: OpenSSL related
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 17:03:37 2021 UTC