php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #81271 Issue tracker: Allow categorizing reports about bugs.php.net ITS
Submitted: 2021-07-18 15:09 UTC Modified: 2021-07-24 00:52 UTC
From: chealer at gmail dot com Assigned:
Status: Re-Opened Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chealer at gmail dot com
New email:
PHP Version: OS:

 

 [2021-07-18 15:09 UTC] chealer at gmail dot com
Description:
------------
This tracker categorizes tickets about meta-issues affecting this very issue tracking system in the "PHP.net Website problem" package. There are many issues with the ITS, but even more other php.net problems, so identifying the ITS-specific issues is time-consuming. Several reporters tried to use conventions about ticket titles to distinguish tickets about bugs.php.net, but some are undesirable, and there are too many:
Starting with "[bugsnet]": https://bugs.php.net/bug.php?id=78962
Starting with "[bugs.php.net]": https://bugs.php.net/bug.php?id=67657
Starting with "[Bug tracker]": https://bugs.php.net/bug.php?id=70411
Starting with "[BugTracker]": https://bugs.php.net/bug.php?id=70411
Starting with "Issue tracker:": https://bugs.php.net/bug.php?id=77354
Starting with "ITS:": https://bugs.php.net/bug.php?id=77356

My own preference is for "Issue tracker", but even I had to use "ITS", because my title wouldn't fit in the limited number of characters allowed had I used the former.

Adding a unique way to specifically categorize ITS tickets would uniformize and greatly diminish the risk of duplicate reports.

Test script:
---------------
This does not report a bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-18 15:21 UTC] danack@php.net
-Status: Open +Status: Not a bug
 [2021-07-18 15:21 UTC] danack@php.net
Reporting issues about how you find the tracker difficult to use, when you haven't made any contributions is not helping.

It takes up time from people triaging the bugs, and figuring out if they need to be urgently looked at.

Please can you stop opening issues like these until you've made a code contribution. If you're looking for stuff to work on, the docs at https://github.com/php/doc-en and https://github.com/php/doc-fr are there for PRs.
 [2021-07-18 22:55 UTC] salathe@php.net
-Status: Not a bug +Status: Re-Opened
 [2021-07-18 22:55 UTC] salathe@php.net
> [2021-07-18 15:21 UTC] danack
>
> Reporting issues about how you find the tracker difficult
> to use, when you haven't made any contributions is not helping.
>
> Please can you stop opening issues like these until you've made
> a code contribution. 

Note: the above quoted comments do not represent the views of the PHP project.

There is no requirement for any issue author to have made any sort of contribution, code or otherwise, to any part of the PHP project before raising a ticket in the issue tracker at bugs.php.net for any type of issue, for any part of the project.  Requesting that an issue author stop creating tickets in the issue tracker until they have contributed code to the project is absurd.
 [2021-07-24 00:52 UTC] chealer at gmail dot com
Having contributed to the PHP ecosystem for over 15 years on a volunteer basis, and having contributed to PHP itself for more than a decade often without much obligation, I find danack's comment not only appalling, but highly discouraging.

That's why I must thank salathe for standing up to defend our values, restoring my motivation and trust in the process. Congratulations


That being said, danack is right about this issue not being a bug. Also, trying to make this constructive, I kind of understand why triage may cause distress. It would surely help if the ITS facilitated tracking each issue's urgency. I encourage you to request a field to track issue importance (if that wasn't already done).
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 01:03:37 2021 UTC