php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #81181 RFC implicit-float-int-deprecate not mentioned in UPGRADING
Submitted: 2021-06-20 08:13 UTC Modified: 2021-06-20 08:43 UTC
From: herbert at groot dot jebbink dot nl Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 8.1.0alpha1 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: herbert at groot dot jebbink dot nl
New email:
PHP Version: OS:

 

 [2021-06-20 08:13 UTC] herbert at groot dot jebbink dot nl
Description:
------------
The RFC https://wiki.php.net/rfc/implicit-float-int-deprecate is not mentiod in the UPGRADING document under "Deprecated Functionality"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-20 08:23 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2021-06-20 08:23 UTC] requinix@php.net
Yes it is.
 [2021-06-20 08:27 UTC] herbert at groot dot jebbink dot nl
The main page at php.net points to https://github.com/php/php-src/blob/php-8.1.0alpha1/UPGRADING and searching for 'float' on this page does not find it.
 [2021-06-20 08:30 UTC] requinix@php.net
Unfortuantely nikic does not have a time machine, otherwise the fix that was made the first time you reported this problem would have been present in alpha 1. You'll have to settle for it being available in alpha 2.
 [2021-06-20 08:35 UTC] herbert at groot dot jebbink dot nl
ok, I see it is fixed in trunk, thanks for the quick replies, I wil check trunk in future bug submits first

btw, I reported it only one time, the first time must be someone else.
 [2021-06-20 08:43 UTC] requinix@php.net
Ahhh, you're right, the bug I'm thinking of was indeed reported by someone else. The summaries are quite similar so I thought this one was a duplicate of the other. I apologize for my snarky replies.

https://bugs.php.net/bug.php?id=81150
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 18:03:36 2021 UTC