php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81094 www.conf file bug
Submitted: 2021-06-01 15:20 UTC Modified: 2021-06-02 10:28 UTC
From: zerqjehan at gmail dot com Assigned:
Status: Not a bug Package: FPM related
PHP Version: 7.4Git-2021-06-01 (Git) OS: Ubuntu Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zerqjehan at gmail dot com
New email:
PHP Version: OS:

 

 [2021-06-01 15:20 UTC] zerqjehan at gmail dot com
Description:
------------
"listen = /run/php/php7.4-fpm.sock"

This is written in default 'www.conf' located at '/etc/php/7.4/fpm/pool.d/'

It should have been like in other versions before:

"listen = /var/run/php/php7.4-fpm.sock"

You are missing '/var' in this line.

This creates problem when configuring with Nginx because by default Nginx is reffering to socket placed at '/var/run/php/php7.4-fpm.sock'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-01 15:32 UTC] rtrtrtrtrt at dfdfdfdf dot dfd35
nonsense!

/var/run is for years a symlink to /run which is tmpfs
are 10 years not enough for you?
https://unix.stackexchange.com/questions/13972/what-is-this-new-run-filesystem
 [2021-06-01 18:58 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: *Web Server problem +Package: FPM related
 [2021-06-01 18:58 UTC] requinix@php.net
Ubuntu/Debian is the one who bundles php-fpm for distribution with their operating system, not us.

But as mentioned, Ubuntu symlinks /var/run to /run, so technically using /run is more correct.
 [2021-06-02 10:28 UTC] zerqjehan at gmail dot com
Not a bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Aug 01 15:01:24 2021 UTC