php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #81081 php8 requires Visual Studio 2019
Submitted: 2021-05-25 11:58 UTC Modified: 2021-05-31 21:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: maggus dot staab+php at googlemail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 8.0.7RC1 OS: windows10 x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: maggus dot staab+php at googlemail dot com
New email:
PHP Version: OS:

 

 [2021-05-25 11:58 UTC] maggus dot staab+php at googlemail dot com
Description:
------------
the manual page: https://php.net/install.windows.requirements mentions the requirements regarding 'Microsoft Visual C++ Redistributable' for php 5 and php 7.

it misses this instructions for php8 (which requires a newer version then php 7.4).

would be great this could be added.

I tried finding the source for for this manual page on the github organisation, but wasn't able to find it


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-05-25 12:06 UTC] cmb@php.net
> (which requires a newer version then php 7.4)

Not really.  For a long time Microsoft distributes the Visual C++
Redistributable for Visual Studio 2015-2019 which works for all
PHP 7 and 8 (so far).

Anyway, the sources of that manual page are at
<https://github.com/php/doc-en/blob/98f2a733bc07e1c6d8fddb1d865b09fd79bdbea2/install/windows/index.xml#L33>.
 [2021-05-25 13:09 UTC] maggus dot staab+php at googlemail dot com
I am wondering why I had to update the 'Microsoft Visual C++ Redistributable' package, since I got a lot of warnings using php 8.0.6 for some extensions.

something like 'extension linked with version xy cannot be loaded' or similar.

on the very same workstation php 7.4 worked without problems, therefore I came to the conclusion that with php 8.x something changed.
 [2021-05-31 08:23 UTC] krakjoe@php.net
-Assigned To: +Assigned To: cmb
 [2021-05-31 08:23 UTC] krakjoe@php.net
Christoph since windows things are happening here, and I don't understand if any further action is required (I think it's not), can you wrap this one up when done please :)
 [2021-05-31 21:00 UTC] cmb@php.net
-Status: Assigned +Status: Not a bug
 [2021-05-31 21:00 UTC] cmb@php.net
Indeed, there is nothing to do regarding the docs.

@maggus: as of Visual Studio 2015, the main DLL is called
vcruntime140.dll, and new versions of the MSVC runtime are
supposed to be compatible with all PHP 7 versions and PHP 8.0 (and
likely 8.1).  You likely had installed an old runtime; these are
supposed to be compatible as well (otherwise MS would have
increased the version number), but PHP makes double sure that the
runtime is up to date for the PHP version.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 09:01:23 2021 UTC