php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #81 Problems using php3.cgi in alias directories
Submitted: 1998-02-18 17:34 UTC Modified: 1998-04-18 11:16 UTC
From: achim at weisz dot de Assigned: rasmus (profile)
Status: Closed Package: Other
PHP Version: 3.0b4 OS: Linux version 2.0.34
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
32 + 10 = ?
Subscribe to this entry?

 
 [1998-02-18 17:34 UTC] achim at weisz dot de
I am using the cgi version of php with apache 1.2.5.
If I set an alias in the srm.conf file of apache, I can't 
execute php scripts in these aliased directories.

It seems that the path to the script is not correctly passed 
to the php.cgi bin. In the source, php constructes the path
to the sript by concatenating document_root and path_info.

I think the correct way would be to concatenate document_root
and path_translated ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-04-18 11:16 UTC] rasmus
This bug is outdated
 [2019-10-23 10:53 UTC] cmb@php.net
Automatic comment on behalf of cmbecker69@gmx.de
Revision: http://git.php.net/?p=pftt2.git;a=commit;h=332325c23940184aaa90ef97c76583a66b034767
Log: Fix #81: Lower-casing of PHPT file names can break tests
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 15:03:36 2022 UTC