php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80967 FILTER_VALIDATE_EMAIL fails on Russian email address поддержка@почта.рус
Submitted: 2021-04-18 09:57 UTC Modified: 2021-04-18 10:29 UTC
From: divinity76 at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: *Mail Related
PHP Version: 8.0.5RC1 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
17 + 50 = ?
Subscribe to this entry?

 
 [2021-04-18 09:57 UTC] divinity76 at gmail dot com
Description:
------------
поддержка@почта.рус is a real email address, but FILTER_VALIDATE_EMAIL fails to validate it, regardless of FILTER_FLAG_EMAIL_UNICODE

Test script:
---------------
<?php
var_dump(filter_var('поддержка@почта.рус', FILTER_VALIDATE_EMAIL, FILTER_FLAG_EMAIL_UNICODE));

Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-04-18 10:29 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2021-04-18 10:29 UTC] cmb@php.net
Duplicate of request #39469.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 17 10:03:37 2021 UTC