php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80954 Error: Call to undefined function mb_ord()
Submitted: 2021-04-15 08:39 UTC Modified: 2021-04-15 08:41 UTC
From: erwan1309 at hotmail dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 8.0.3 OS: Ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: erwan1309 at hotmail dot com
New email:
PHP Version: OS:

 

 [2021-04-15 08:39 UTC] erwan1309 at hotmail dot com
Description:
------------
---
From manual page: https://php.net/function.mb-ord
---
Env: PHP 8.0.3 (cli) (built: Mar  5 2021 07:54:13)
OS : Ubuntu 20

mb_ord() does not exist.

I get an error with the local dev server (php -S)

Uncaught Error: Call to undefined function mb_ord()




Test script:
---------------
<?php
echo mb_ord('€');


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-04-15 08:40 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2021-04-15 08:40 UTC] nikic@php.net
You either did not install or did not enable the mbstring extension.
 [2021-04-15 08:41 UTC] requinix@php.net
-Status: Not a bug +Status: Feedback
 [2021-04-15 08:41 UTC] requinix@php.net
Did you install and/or enable the mbstring extension?
 [2021-04-15 08:41 UTC] requinix@php.net
-Status: Feedback +Status: Not a bug
 [2021-04-15 08:41 UTC] requinix@php.net
Yeah, might as well just go with that.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 18:01:33 2024 UTC