php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #80939 error: 'asm goto' constructs are not supported yet
Submitted: 2021-04-06 18:46 UTC Modified: 2021-04-06 20:19 UTC
From: nbennett25 at yahoo dot com Assigned:
Status: Closed Package: PECL (PECL)
PHP Version: 7.3.27 OS: Mac 10.15.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nbennett25 at yahoo dot com
New email:
PHP Version: OS:

 

 [2021-04-06 18:46 UTC] nbennett25 at yahoo dot com
Description:
------------
php 7.3.26, installed via brew
newest version of Xcode cli tools installed
running sudo pecl install xdebug yields the following error:

/usr/local/Cellar/php@7.3/7.3.26/include/php/Zend/zend_operators.h:486:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.3/7.3.26/include/php/Zend/zend_operators.h:536:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.3/7.3.26/include/php/Zend/zend_operators.h:593:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(
                ^
/usr/local/Cellar/php@7.3/7.3.26/include/php/Zend/zend_operators.h:683:10: error: 'asm goto' constructs are not supported yet
        __asm__ goto(


Test script:
---------------
brew install php@7.3
sudo pecl install xdebug

Expected result:
----------------
sudo pecl install xdebug returns successful

Actual result:
--------------
Error returned

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-04-06 18:54 UTC] levim@php.net
-Operating System: 10.15.7 +Operating System: Mac 10.15.7
 [2021-04-06 18:54 UTC] levim@php.net
What is the output of `clang --version`? I suspect you need to update xcode. Arguably there is still some bug here on PHP's side, but if your clang version isn't "Apple clang version 12.0.0" or newer then I suspect upgrading xcode will fix the problem on your side.
 [2021-04-06 18:56 UTC] levim@php.net
To be clear: if you aren't on clang 12, then you need to install updates to xcode through the Software Update panel or whatever. I am sure there is a way to do it on the CLI, but I don't know what it is -- `xcode-select` does not have an update flag or anything like that.
 [2021-04-06 20:19 UTC] nbennett25 at yahoo dot com
-Status: Open +Status: Closed
 [2021-04-06 20:19 UTC] nbennett25 at yahoo dot com
Thx levim@php.net - that did the trick. 

I had updated the Xcode cli tools using Xcode-select install via the cli, but that did *not* install the updated clang. I updated Xcode through the App Store, and clang was updated to 12.x, and the xdebug install worked as expected.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 05:03:39 2021 UTC